Connection issues with multiple services
Incident Report for Trimble Tekla
Resolved
It appears there was a issue related to multiple public DNS servers. These DNS servers provide Name resolution services for the internet in general and as a result users connecting to these servers may have experienced issues with numerous services, not just ours.

During this time our services were working perfectly but some customers may have experienced connectivity issues as a result.
Posted May 06, 2022 - 13:45 EEST
Monitoring
All our services have been checked and appear to be operating normally.

We have recieved reports of a DNS issue with multiple DNS servers globally reporting timeouts which has had a direct effect on users ability to connect to our services.

The situation appears to be returning to normal.

We are continuing to montior the situation.
Posted May 05, 2022 - 23:54 EEST
Investigating
We have had reports of users from mulitple regions having issues connecting to various services. We believe these to be DNS issues beyond our control but are investigating as a matter of urgency.

We are sorry for the inconvenience.
Posted May 05, 2022 - 17:30 EEST