Planned Maintenance on Trimble Downloads Service

Maintenance

Planned Maintenance on Trimble Downloads Service

Status: closed
Start:
End:
Duration: 1 hour
Affected Components:
Trimble Downloads
Update

Dear Customer,

Please be notified regarding the forthcoming planned maintenance window detailed below:

Affected Services: Trimble Downloads
Start Date and Time: September 29 2025, 06:00 UTC
Expected Duration: 1h
Planned End Date and Time: September 29 2025, 07:00 UTC

We apologize for any inconvenience this may cause.

Resolved

Dear Customer,

Planned Maintenance Affecting Service(s): 
Trimble Downloads

Please be advised that the previously notified maintenance has been completed successfully.