Tekla Online Admin Tool is down during a maintenance update
Incident Report for Trimble Tekla
Resolved
Tekla Online Admin Tool is up again. You can use the service as usual at https://admin.account.tekla.com/
Posted Oct 03, 2023 - 11:05 EEST
Update
While we continue working on the maintenance update, you can access Tekla Online Admin Tool here: https://admin-new.account.tekla.com/
Posted Oct 03, 2023 - 10:58 EEST
Identified
We expect the service to be up in one hour (by 11 AM Finland time).
Posted Oct 03, 2023 - 09:57 EEST
This incident affected: Authentication and Online licensing (Tekla Online Admin Tool).