Tekla Downloads maintenance break
Scheduled for Oct 22, 10:00 - 11:00 EEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 16, 2024 - 14:14 EEST
Scheduled
We will have a maintenance break in Tekla Downloads service on Tuesday, October 22nd starting at 10:00AM EET (UTC +03:00). We estimate the break to last for about one hour. The service might be unavailable for some time during the maintenance break. We are sorry for the inconvenience.
Posted Oct 16, 2024 - 12:43 EEST
This scheduled maintenance affects: Tekla Downloads.