As planned Tekla Model Sharing service now accepts only TLS 1.2 connections
Incident Report for Trimble Tekla
Resolved
The model sharing service now only accepts TLS 1.2 connections.
Posted Jan 17, 2022 - 08:10 EET
Investigating
As planned and informed, from 17th of January 2022 onwards, Tekla Model Sharing service will accept only TLS 1.2 capable Tekla Structures versions and operating systems. In case you cannot connect to the model sharing service check that you have made all the needed updates and patches for your Tekla Structures installations.

For more information, see this product bulletin: https://support.tekla.com/article/security-update-for-tekla-model-sharing
Posted Jan 17, 2022 - 08:07 EET
This incident affected: Tekla Model Sharing services (Tekla Model Sharing - 2019 and newer, Tekla Model Sharing - 2018i and older, Tekla Model Sharing - Management Console).