Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2025 - 13:00 EET
Scheduled
With this update, the Tekla Model Sharing service will include the following new features:
1. Malware Scanning: New write-out changes to models will be scanned for malware. Any potential malware findings will be displayed in the Management Console, and both the write-out user and model owners will be alerted via email.
2. Enhanced Management Console: The Management Console now allows a single user account to manage multiple organizations. This is based on the administrator roles assigned in the Tekla Online Profile (account.tekla.com).
No downtime for the services are expected with this update.
Posted Mar 07, 2025 - 14:16 EET
This scheduled maintenance affected: Tekla Model Sharing services (Tekla Model Sharing - 2019 and newer, Tekla Model Sharing - Management Console).