Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 23, 2025 - 20:00 EEST
Scheduled
We will perform infrastructure related maintenance operations on Saturday, August 23rd starting at 8PM EEST. We estimate that the activities will last for about 15 minutes.
This will cause a short interruption in Tekla web services and in the on-premises FlexNet licensing system. We recommend avoiding Tekla Structures license activation and deactivation during the service break.
Posted Aug 11, 2025 - 16:53 EEST
This scheduled maintenance affected: Authentication and Online licensing (Online Profile, Tekla Online Admin Tool, Tekla Account Service (TAS), Tekla Subscription Tool), Tekla Model Sharing services (Tekla Model Sharing - 2019 and newer, Tekla Model Sharing - Management Console), Tekla Online side pane (Tekla Online side pane, Tekla Structures, Tekla Online side pane, Tekla Structural Designer, Tekla Online side pane, Tekla Tedds), Fabrication Drawings (Preview) (Fabrication Drawings (Preview), Fabrication Drawings Console (Preview), Fabrication Drawings Permissions Service (Preview)), and On-premises FlexNet licensing system, Tekla Warehouse, Trimble Downloads, Tekla Developer Center, Tekla Discussion Forum, Tekla website, Tekla User Assistance, Tekla Environment Service (Preview), Tekla Support Service, Tekla Support Tool, Trimble Assistant for Tekla (Preview).